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1. Introduction (back to contents) 

1.1 Explanation 

We have written RASP (Reconstruct Ancestral State in Phylogenies) software to implements Dispersal-Vicariance Analysis 

(S-DIVA), Lagrange (DEC model), Bayes-Lagrange, BayArea and Bayesian Binary MCMC (BBM)methods. RASP is easy-

to-install on the Windows, Mac, and Linux platforms, provides a user-friendly graphical interface, and generates exportable 

graphical results. 

In RASP, the module of S-DIVA analysis is modified from source code of DIVA 1.2 (Ronquist, 2001) and the MCMC 

analysis in BBM is modified from source code of Mrbayes 3.1.2 (Ronquist & Huelsenbeck, 2003). DEC model of geographic 

range evolution was described in Ree et al. (2005) and Ree & Smith (2008). DEC analysis is modified from source code of 

C++ version of Lagrange developed by Smith (2010). BayArea method was described in Landis et al. (2013) 

1.2 Citation 

Program: 

Yu Y, Harris AJ, Blair C, He XJ. 2015. RASP (Reconstruct Ancestral State in Phylogenies): a tool for historical 

biogeography. Molecular Phylogenetics and Evolution. DOI:10.1016/j.ympev.2015.03.008 

S-DIVA method: 

Yu Y, Harris AJ, He XJ. 2010. S-DIVA (statistical dispersal-vicariance analysis): a tool for inferring biogeographic histories. 

Molecular Phylogenetics and Evolution. 56(2): 848-850 

DEC model (Lagrange): 

Ree, R H and S A Smith. 2008. Maximum likelihood inference of geographic range evolution by dispersal, local extinction, 

and cladogenesis. Systematic Biology. 57(1): 4-14.  

S-DEC method 

Beaulieu, J.M., Tank, D.C., Donoghue, M.J., 2013. A Southern Hemisphere origin for campanulid angiosperms, with traces 

of the break-up of Gondwana. BMC Evolutionary Biology. 13(1), 80.  

Bayarea: 

Landis M J, Matzke N J, Moore B R, et al. 2013.Bayesian analysis of biogeography when the number of areas is large. 

Systematic biology. 62 (6): 789-804  

BBM: 

Ronquist F, Huelsenbeck JP (2003) MrBayes3: Bayesian phylogenetic inference undermixed models. Bioinformatics 
19:1572–1574. 
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2. Installing (back to contents) 

For windows users: 
Supported Operating Systems: Windows 2000 and above(Recommend Win 7) 
System Requirement:  

If you are using Windows 2000, 2003 or XP, please make sure that Microsoft® .NET 3.5 Framework is installed on your 
computer. This is usually installed through Windows updates but may be absent from older systems. The .NET 
framework 3.5 packages are available for free or you could use the small Client Package for Win XPand should be 
installed prior to using RASP. 

 
For Mac users: 
Supported Operating Systems: 10.6.x and above (Recommend 10.10.x). 
System Requirement:  

This version of RASP is developed for use on Mac OS X versions 10.6 and above on computers with Intel processors 
only. RASP for Mac uses the Wine program in order for RASP to run.  

RASP using the Wineskin wrapper, and Mac OS X’s user folders are mapped as following: 
Desktop->Desktop 
Documents->My Documents 
Visiting “\” may crash RASP for security reason. 
Most Mac users have reported positive experiences when using RASP. However, we also have received feedback from some 
Mac users that have experienced stability issues. 
If you have problems, you could try to run RASP using virtualization or emulation software. Many options for doing so are 
available including Parallels (commercial), Crossover (commercial), VM WareFusion (commercial) or VirtualBox (free). 
 
For Linux users: 
There are very few people using the Linux version of RASP, so we will not update the old version of RASP for Linux. RASP 
has been not officially supported on the Linux platform since 2012. RASP could be run successfully on Linux using WINE. 
 
IMPORTANT NOTE FOR ALL PLATFORMS:  

Please make sure that the decimal symbol of your system is ‘.’ 
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3. A general tour of RASP(back to contents) 

3.1 Preparation 

You need: 
1.   Trees data set 

(A sample trees data file: “[RASP folder]\Sample\Rubiaceae\RASP\1000_trees.trees”) 
  -[How to]: How to obtain trees data set from BEAST (Drummond and Rambaut, 2006) 

-[How to]: How to obtain trees data set from PAUP (Swofford, 2003)  
-[How to]: How to obtain trees data set from other phylogenetic programs. 

2.   Condensed tree 
(A sample condensed tree: “[RASP folder]\Sample\Rubiaceae\RASP\condensed.tre”) 

  -[How to]: How to make a condensed tree using BEAST. 
-[How to]: How to make a condensed tree using PAUP. 
-[How to]: How to obtain a condensed tree from other phylogenetic programs. 

3. Distributions file (not required).  
(A sample distributions file: “[RASP folder]\Sample\Rubiaceae\RASP\distribution.csv”) 
-[How to]: How to input distributions in RASP. 

 -[How to]: How to make a Distributions file. 
 
Launch RASP 
Note for Mac user: You could put “Sample” folder (and your own data) in Desktop or Documents folder for convenience. 
1. Open [File > Load Trees> Load Trees] and navigate to your trees data set and select it. 
[Example: Open “[RASP folder]\Sample\Rubiaceae\RASP\1000_trees.trees” in folder Sample] 
Note1: In Lagrange, BayArea and BBM analysis, only one condensed tree is needed 
Note2:If you have one tree only, you could load it and jump to step 3. 
Note3: For a large dataset, one can try [File > Load Trees > Quick Load] to be faster, but only trees exported from Beast and 
mrbayes were supported. 
 
2. Open [File>Load Condensed tree], navigate to your tree file and select it. 
[Example: Open “[RASP folder]\Sample\Rubiaceae\RASP\condensed.tre” in folder Sample] 
 
Do not have a condensed tree: use [File>Load Condensed tree>Compute From Trees Dataset] to build one. 
Note1: The consensus tree computed by RASP do not contain branch length, so it could NOT be used for Lagrange, Bayes-
Lagrange and BayArea analysis (could be used in S-DIVA and BBM). We strongly recommend user to use their won 
condensed tree with branch length. 
Note2: The condensed (consensus) tree will be a majority rule consensus with compatible groups with less than 50% support 
allowed. The tree consensus is computed using Consense (Felsenstein, 1993) from your trees file or from the subset of trees 
from the file you have specified (i.e., see the Random Trees, and Discard Trees options below). 
 
3. If you have a distributions file:Open [File > Load Distribution], navigate to your file and select it. 
[Example: Open “[RASP folder]\Sample\Rubiaceae\RASP\distribution.csv” in folder Sample] 
You can also input and revise the distributions in the entry fields in the Distribution column in RASP. 
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3.2Check status 

Binary trees: The total number of binary trees in your trees data set.  
Amount of trees: The total number of trees in your trees data set.  
Note: The Statistical Dispersal-Vicariance Analysis, Lagrange and Bayes-
Lagrange requires binary trees while Bayarea and Bayesian Binary MCMC 
Method accepts one polytomies tree. Lagrange, Bayes-Lagrange and 
Bayarea require trees with branch length. 
 
Discard trees: The number of trees that will be discarded from the beginning 
of the trees data set; equivalent to a burnin. 
 
Random tree: Select random trees form trees data setto run the Statistical 
Dispersal-Vicariance Analysis and Bayes-Lagrange. Trees will be selected 
from between Discard Trees and Amount of trees. You can save the randomly 
selected trees to a new file with [File>Export Trees ->Random Trees] after 
analysis has been done. 
 
Current Condensed tree: Show the condensed tree in text. You could view 
your condensed tree in graphic form [Graphic > Tree View] 
 
CHECK STATUS: Check the current status of RASP. 
 
Note: We recommend users to click “CHECK STATUS” after any change of 
their trees or distributions. It will show useful error and warning messages, 
and tell you which analysis could be done at the current status. 
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3.3 Analysis 

3.3.1. Statistical Dispersal-Vicariance Analysis 
Note: S-DIVA Analysis will deal with BOTH CONDENSED TREE AND TREES DATESET 
Choose [Analysis > Statistical DispersalVicariance Analysis (S-DIVA)] to use default options to run Analysis. 

 
[Options] 
Include -> and Exclude-<: Include or exclude ranges from calculation. This can be accomplished by selecting ranges from 
the Include list and clicking the arrow to move them to exclude. When you do this, only the selected ranges will be excluded. 
You can also exclude all ranges that include a particular subset of areas using the range matrix. For example, unchecking the 
box in the first row, second column will remove all ranges that include A and B; AB and ABC in the example above. Once 
the desired boxes have been unchecked, [Operation> Refresh the Range List].  
We modified the source code of DIVA (Ronquist, 2011) to exclude impossible ranges.  
Max areas at each node: The number of unit areas allowed in ancestral distributions. 
Allow Extinction (Slow): Traditionally, there are four different biogeographic events under the event model in DIVA: 
dispersal, extinction, vicariance and duplication (Ronquist, 1997). In original DIVA algorithm, there is no need for calculating 
(Ronquist, 2001) the cost of extinction events. if some user-specified ranges are excluded, a null (or empty) result may occur; 
namely if the only geographic ranges that are consistent with the rule have been eliminated. For example, suppose that the 
total distribution is {A, B, C}, NL = A and NR = B. When geographic range AB is excluded, ABC should be proposed as the 
ancestral range, but ABC violates the rule set of the DIVA algorithm. Therefore, we have made the following modification in 
S-DIVA: Assume that the ancestral range of the node, i, is Ai, then the descendant nodes (terminal) are NL and NR. Let |X| be 
the number of elements in X. Then the cost of an extinction event Ei could be calculated as |𝐴#| − |𝑁&⋃𝑁(⋂𝐴#|. When no 
ranges are excluded, the algorithm of S-DIVA is as same as DIVA. 
Allow Reconstruction: Unchecking this option changes the method used for calculating F(xn) from i/Dt to 1/N. Also see Yu 
et al. (2010) and Harris & Xiang (2009) in which the differences between these options are discussed.  
Max Reconstructions: Total number of reconstructions will be kept for each tree in trees dataset. 
Random Reconstructions: Save random reconstructions. We strongly recommend kept this option checked or it will cost a 
very long time and a large disk space to do the analysis. 
Max Reconstructions for final tree: Total number of reconstructions will be kept for final tree. 
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3.3.2. Bayesian Binary MCMC (BBM) Method For Ancestral State 
Note: BBM Analysis will deal with CONDENSED TREE ONLY 
Choose [Analysis >Bayesian Binary MCMC (BBM)] to use default options to run Analysis. 

 
[Area] 
Maximum number of areas: The number of unit areas allowed in ancestral distributions. 
Allow null distribution in analysis: If the null distribution was allowed. 
 
[Markov Chain Monte Carlo analysis] 
Note: The MCMC analysis is built from source code of Mrbayes 3.1.2. We recommend reviewing these options in the 
Command Reference for MrBayes (Ronquistand & Huelsenbeck, 2005) 

BBM is primarily designed for reconstructing ancestral state of given nodes. It calculates the probabilities of ancestral 
ranges using the probabilities of each unit area generated by MrBayes. In RASP, we use the source code of MrBayes 3.1.2 
(Ronquist & Huelsenbeck, 2003) to build the module of Bayesian biogeographic inference. Like BayArea, binary character 
states are used to code geographic range in BBM. Assume that D = {X1, X2 … Xn} is the set of all unit areas and that R = {Y1, 
Y2…Y2

n} is all possible combinations of unit areas; in other words, all possible ranges. The terms P1(Xi) and P0(Xi) represent 
the average probability of presence (1) and absence (0) over all sampled generations generated by MrBayes, respectively, of 
the ancestral species in area Xi. The probability of an ancestral range in set R is calculated as: 

𝑃 𝑌# = 𝑃- 𝑋/
01∈31

𝑃4 𝑋5
01∈ 6∩31 8

   

BBM does not consider the branch length and support value of the tree, and itaccepts trees with polytomies directly 
giving the researcher more flexibility in analysis. Researchers also have the ability to collapsebranches that they do not wish 
to utilize (i.e. branches with low support value) in BBM. In BBM, “null range” (an ancestral range contains none of the unit 
areas) could be removed after the MrBayes analysis. The null range is useful in ancestral state reconstruction (e.g., flower 
spots; flowers with red spots are A, with yellow spots are B, then without spots have the “null range”), but does not make any 
sense in biogeographic analysis.  
Number of cycles (Ngen in Mrbayes): This option sets the number of cycles for the MCMC algorithm. 
Number of chains (Nchains in Mrbayes): How many chains are run for each analysis for the MCMC variant. 
Frequent of samples (Samplefreqin Mrbayes): This specifies how often the chain is sampled. 
Discard samples (burnin in Mrbayes): This option determines how many samples will be discarded before calculating the 
partition frequencies. 
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Temperature (Temp in Mrbayes): The temperature parameter for heating the chains. 
 
Node List :In Bayesian Binary MCMC Analysis, you can deselect nodes to exclude them from the analysis. Using the 
Select > n% options, you can select all nodes supported by posterior probability (pp) greater than your specified value. 
Note: In order to select nodes with greater than n% pp support, 
 
[Model] 
Note: There are four models in Bayesian Binary MCMC Analysis: JC, JC+G, F81, F81+G 
State frequencies: Character state frequencies. 
Among-site rate variation: This parameter specifies the prior for the gamma shape parameter for among-site rate variation. 
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3.3.3. Lagrange (Dispersal-Extinction-Cladogenesis, DEC model) 
Note: Lagrange Analysis will deal with CONDENSED TREE ONLY 
Note:For Lagrange and Bayes-Lagrange, we usebiogeography of the Hawaiian shrub Psychotria, as a sample dataset. You 
could load the data from“[RASP folder]\Sample\Psychotria\” 
Choose [Analysis >Lagrange (Dispersal-Extinction-Cladogenesis, DEC)] to use DEC models of geographic range 
evolution described in Ree et al. (2005) and Ree and Smith (2008). This module use source code of c++ version of Lagrange 
developed by Smith (2010) and is much more faster than the Python version of Lagrange. 

 
Include -> and Exclude-<: Include or exclude ranges from calculation. This can be accomplished by selecting ranges from 
the Include list and clicking the arrow to move them to exclude. When you do this, only the selected ranges will be 
excluded. You can also exclude all ranges that include a particular subset of areas using the range matrix. For example, 
unchecking the box in the first row, second column will remove all ranges that include A and B; AB and ABC in the 
example above. 
Maximum areas: The number of unit areas allowed in ancestral distributions.  
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The  right  table  of  the  form  designates  what  time  slices  or  periods  will  be  considered.  This  is  important  when  designating  
the  above  matrix  if  different  connectivities  are  used  for  different  times,  and  it  can  also  be  important  when  estimating  the  

rate  matrix  parameters  if  you  want  different  estimates  for  different  time  periods.  
You  could  add  or  remove  the  periods  from  the  table  using  the  “Add”  or  
“Remove”  button.  The left part of the form contains the rate matrix connectivity 
parameterization. 
For  instance,  the  left  matrix  says  that  for  the  period  1  to  2  (In  time  table,  from  0.5  
to  1.9)  there  is  less  dispersal  between  areas  D  and  A.  And  in  the  period  from  0  to  
1,  all  dispersalrates  are  equal  to  1.  
You  could  export/import  the  matrix  to/from  file.  

[Example:  Open “[RASP folder]\Sample\Psychotria\timeperiods.txt”]  
  
  
  
  
  

  
Select  two  species  to  define  a  clade  and  then  specify  the  ancestraldistribution  of  the  clade.  This  is  used  when  wanting  
ancestral  state  results  for  only  particular  nodes  (for  instance,  there  are  fossils  on  the  node).  
  
 
 
3.3.4. Bayes-Lagrange (Statistical DEC Model) 
Choose [Analysis >Bayes-Lagrange (Statistical DEC, S-DEC)] to use Bayes-Lagrange model 
Note: Bayes-Lagrange Analysis will deal with BOTH CONDENSED TREE AND TREES DATESET 
Bayes-­‐LAGRANGE  approach  it  is  possible  to  optimize  on  multiple  trees  whereby  topological  uncertainty  is  taken  into  
account.  RASP  get  the  likelihood  values  of  all  possible  ancestral  distributions  in  Lagrange,  and  relied  on  a  composite  Akaike  
weight  to  summarize  the  biogeographic  reconstructions  across  trees  (Beaulieu  et  al.,  2013).  The  settings  are  as  same  as  
above.  Bays-­‐Lagrange  is  not  really  Bayesian,  but  more  like  pseudo-­‐Bayesian.  I  prefer  to  call  it  as  S-­‐DEC  model.  
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3.3.5.Bayarea (Bayesian inference for discrete areas) 
Choose [Analysis >BayArea (Bayesian inference for discrete Areas)] to use Bayes-Lagrange model 
Note: Bayarea Analysis will deal with CONDENSED TREE ONLY 

  

If  you  have  a  Geographicdata  file,  click[Load]button,  navigate  to  your  file  and  select  it.  
[Example:  Open  “[RASP  folder]\Sample\Rubiaceae\RASP\coordinates.csv”  in  folder  Sample]  
You  can  also  input  and  revise  the  coordinates  in  the  entry  fields  in  the  Geographicdatacolumn.  
The  following  settings  are  described  in  BayArea’s  manual  (Landis,  2013):  
Chain  length:Number  of  MCMC  cycles.  
Frequent  of  sample:The  MCMC  sample  frequency  to  populate  area  states  and  probabilities.  
GuessInitialRates:  Use  heuristic  to  initialize  MCMC  area  loss/gain  rates  (Landis,  2013).  
Geo  Distance  Power:Constrains  the  distance  power  parameter  to  be  positive  when  True.  This  may  lead  to  more  sensible  
parameter  inferences  when  range  data  are  sparse  and  global.  
Geo  Distance  Truncate:When  True,  the  pairwise  distance  calculator  approximates  extremely  improbable  dispersal  events  
as  having  a  very  small  positive  rate  (effectively  zero).  This  introduces  negligible  error  into  the  analysis,  but  greatly  speeds  
up  computations  when  the  number  of  areas  is  large.  
Save  original  result  to:  save  BayArea  output  files  to  another  place.  To  visualize  your  MCMC  results,  we  recommend  using  
the  “.parameters.txt”  file  with  Tracer  (http://tree.bio.ed.ac.uk/software/tracer/).  

After the MCMC cycle is 
completed, a “tracer view” 
will show. Before the 
calculation of the posterior, 
the chain must first burn-in. 
A small Burn-in value will 
give inaccurate results 
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3.3.6 BayesTraits Command Builder 

  
The  BayesTraits  Command  Builder  could  build  command  for  BayesTraits.  If  you  want  to  convert  the  export  of  BayesTraits  to  
RASP  format,  please  code  the  characters  with  A,  B,  C  etc.  and  use  MultiState  Model.  After  the  commands  are  ready,  please  
click  “Create  Files”  and  save  your  file  in  the  folder  of  BayesTraits.  In  the  Windows  Version  of  RASP,  BayesTraits  could  run  
automatically.  In  the  mac  version  of  RASP,  you  need  to  run  BayesTraits  manually,  and  load  the  *.log.txt  file  from  [File-­‐>Load  
Log]  in  BayesTraits  window.  You  could  also  analysis  the  *.log.txt  file  from  [View-­‐>Distribution  View]  in  the  main  window:  
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3.4 Results 
3.4.1. Save and Load Results 
After running an analysis, you can save the last Result from [File > Save > RASP Result]. The result file could be load into 
RASP from [File > Load Result]. To combine several results, see part 4.4.  
 
3.4.2View results on tree 
After running an analysis, you can access the Tree View window from [Graphic > Tree View] to see the graphic result. 

 



15  
  

[Note: S-DIVA, Lagrange and Bayes-Lagrange only have “Multi-Areas” mode, for they could not give the probabilities of 
each single area] 
[Options] 
Open [View > Option] in Tree View window to show the options. 
Transparent BG: Save PNG file with a transparent background. 
Quick Options: Size of the displayed tree and its annotations.  
Hide areas lower than: Hide areas which probability of lower than a 
specific number. 
Keep at least: How many areas displayed at a node at least. 
Display Lines: Show lines of tree or not. 
Display area distribution: Show distribution areas. These will display as 
colored letters next to the pie charts. 
Display area pies, radii: Show pie charts of distribution area and set the 
radii of pie charts (5-1000). 
Taxon separation: Set the separation of taxa (10-1000). 
Branch length: Set the length of branches (10-1000px). All branches in 
the cladogram become proportionately larger or smaller. 
Border separation: Set the width of the white space in the tree view 
window (10-1000). Note that it is possible to make this too small for the 
width of the tree. 
Line width: Set the width of the line (1-10) 
 

 
[List] page 
result of *: Select a node to display alternative ancestral distributions (pie chart and bar 
chart) at the selected node on thetree. 
Muti Areas, Single Area: two different kind of distribution range pie. TheSingle Area 
only supports result of BBM and BayAreamethod. It shows the probabilities of presence 
of each single area. 
 
 
 
[Information] page 
Applying the DIVA model (Ronquist, 1997) to S-DIVA results can be challenging 
because the former does not accept trees with polytomies. Therefore, we have expanded 
the DIVA event model to a generalized event model, DEV (Dispersal, Extinction and 
Vicariance), which accepts polytomies. (When the tree does not contain polytomies, DEV model is the same with DIVA 
model). Traditionally, there are four different biogeographic events under the event model in DIVA: dispersal, extinction, 
vicariance and duplication (Ronquist, 2001). In the DEV model, we define only three biogeographic events: dispersal, 
extinction, and vicariance. We assume that both dispersal and duplication result from biological processes inducing or leading 
to range expansion. This differs from vicariance, in which abiotic processes subdivide an ancestral geographic range, and 
from local extinction, which results in range contraction. 
To apply the DEV model to biogeographic reconstructions, we consider only the most likely state (MLS) of nodes. Assume 
that the MLS of the ancestral node, i, is Ai, then the descendant nodes (terminal) are N1, N2 … Nj, where j is the total number 

of descendant nodes. We define Nu = Nkk=1

j∪ ,
Ns = Nkk=1

j∩ . Let |X| be the number of elements in X. The variables Di, Ei and Vi 

are the dispersal, extinction and vicariant events of the node i respectively. One can show that:  
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Di =
Nu∪ Ai − Ai , Ai >1

Nu∪ Ai − i* Ns∩ Ai + ( Ai∩Nk )k=1

j
∑ , Ai =1

%

&
'

(
'

Ei = Ai − Nu∩ Ai Vi =
i −1 , Ns∩ Ai = 0

0 , Ns∩ Ai > 0

#

$
%

&
%

  

The DEV event model assumes that the MLS at each node are the true state.  
[Note: the DEV model may misinterpret the actual processes assumed by DEC, BayArea and BBM, as these methods do not 
minimize the number of events using the parsimony process.] 
Dispersal: Highlight the nodes that have Dispersal event. 
Vicariance: Highlight the nodes that have Vicariance event. 
Extinction: Highlight the nodes that have Extinction event. 
 
[Time] page 
Reverse: Convert the branch length from before to nowadays.  
Time of root node: Set the time of the root of the tree. 
Calculate: Re-Calculate the time of each node using the time of the root and calculate the time-event curve. 
In the biogeographical analyse, researchers often interested in the relationship between the nodes and biogeographical events 
on dated phylogenetic tree. However, it might be very difficult to do the analysis on a large and complex tree, especially when 
the molecular dating is not very accurate. The extent of influence of geographical event on phylogenetic tree is hard to define, 
and the qualitative and quantitative analyses are not easy to make. In RASP, we develop a time-events curve to analysis the 
dated phylogenetic tree. The events on the node were treated using a modified Gaussian distribution. Let n be the total number 
of tree, Ti is the time of node i. One can show that, u is the unit time of the events: 
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𝑀 𝑡 = D t + E t + V t  
In these four functions, D(t), E(t),V(t) and M(t) implie the duplication, extinction, vicariance event and the total number of 
biogeographic events through the time respectively. S(t) implies the number of nodes through the time. Noting that the unit 
time of event has a great influence on the shape of time-events curve. One could find an appropriate value according to the 
duration of geological events. 
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The graphic could be saved from [File->Export Graphic->Export Diagram] 
 
[Mouse control] 
[Double click on a node]: Select the node. 
[Double click on blank space]: Cancel node select. 
 
[Save/Loadresults] 
Open [File -> Save Result] to save the text result. 
Open [File -> Save Info] to save the text in Diagram page. 
Open [File -> Save Current Tree] to save the tree in Phylip format. 
Open [File ->Export Graphic ->*] to save your tree/legend/ dtagram as graphic file. 
Note: One could export graphic to vectorial drawing (.svg/wmf file, open with Adobe Illustrator) or picture (.png file). 
Open [File > Load Result] and navigate to your saved text result and select it. 
 
 
3.4.3Node view 
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When “Estimate for nodes” in S-DIVA 
analysis is enabled, you could view the 
results of nodes. You could also view the 
results of nodes in BBM method. The left 
figureshows a result for estimating a 
particular node. This can be accessed 
from [Graphic > Node View]. 
Hide areas lower than: Hide areas which 
probability of lower than a specific 
number. 
Note: Hidden probabilities are lumped 
together and reported as * (see far right 
bar in the figure to the left). In this 
example, ranges with probabilities less than 5% are hidden. 
Keep at least: Fewest number of areas displayed (trumps the Hide areas lower than setting). 
[Save results] 
Open [File -> Save Result] to save the text result. 
 
 
3.4.4Tracer View 
View likelihoodvalue of BayAreaMCMC cycle and re-calculate the result with the new burn-in value. 
This can be accessed from [Graphic > Tracer View] 
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4. How to …(back to contents) 

All sample files referenced in this manual are in the sample folder. 

4.1 How to make Trees data set. 

4.1.1 How to obtain trees data set from BEAST. (Back to Top) 
l   Launch BEAUti v*.exe 
l   Select File > Import Alignment and navigate to your NEXUS input file. 

(From our sample files, we would selectsample1.nex in the Sample folder) 
(Note: If BEAUtican’t load the NEXUS file then load the file into PAUP and export it use “format=NEXUS” 
option.) 

l   Select MCMC panel, set the number of generations the MCMC algorithm will run for.  
(We set length of chain = 1000000 to do a quick run) 

l   Click Generate BEAST file… and save your file. 
(We saved it as samlpe1.xml in sample folder) 
 

l   Launch BEAST v*.exe 
l   Enter a Random number seed like 12345 
l   Choose your BEAST XML input file. 

(From our sample files, we would select sample1.nex in the Sample folder) 
l   Run it!  
l   After the program is finished, you will find a .trees file in the same folder of your.xml file. 

(In our example, Sample1.treesis our trees data set.) 
  
4.1.2 How to obtain trees data set from PAUP. (Back to Top) 

l   Use Lset or Pset command set for ML or MP analysis with option “Collapse= NO;” 
l   Define outgroups and root the trees with “roottrees OUTROOT=MONOPHYL;” 
l   Save all of your trees using “format=NEXUS” option. 

Important: Trees with polytomies could only be used in Bayesian Binary MCMC and MP analysis! 
 

4.1.3   How to obtain trees data set from other phylogenetic programs. (Back to Top) 
If you are using Mrbayes, it is helpful to define outgroups and specify rooting before you run mcmc. If you did not define 
outgroups and specify rooting before the MrBayes run, you can root all trees using PAUP or other available software. 
You can load the MrBayes output file (*.run.t) as your trees data set once the trees have been rooted. 
For other phylogenetic programs, there are two methods for making a trees data set: 
Method 1: 
l   Save the trees as Nexus format from whatever phylogenetic program you are using.  
Method 2: 
l   Save the trees as PHYLIP format.  
l   Load the trees into PAUP then export the trees use “format=NEXUS” option. 
Important: Trees with polytomies could only be used in Bayesian Binary MCMC and MP analysis! 
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4.1.4   The bare essentials for the tree file. (Back to Top) 
Our sample trees file includes considerable amounts of phylogenetic program 

output, but here is what a trees file must contain. An example, which can be 
accepted by RASP, is shown to the left. 
l   Your taxa should have unique labels or names (upper arrow).  
l   Translate your unique taxon names into integers (1- ~) (middle arrow). 

These integers are required for the ID field in the RASP program. 
l   Your file should contain one or more phylogenetic trees in set notation 

(lower arrow). Many tree generating programs such as PAUP*, 
Mrbayes, etc. include a lot of extra information within each tree such 
as branch lengths, likelihood values, and so on. This extra information 
does not hinder RASP, but it is also not essential. 

Note: Some programs used to root trees, place the outgroup at the beginning 
on the tree strong (like the outgroup 3 in the example), others do the 
opposite, placing the outgroup at the end of the strong. RASP can accept 
both types of rooting. 
 

4.2 How to make a Condensed tree. 

4.2.1 How to make a condensed tree by Tree Annotator. (Back to Top) 
l   Launch TreeAnnotator*.exe 
l   Set Burnin and Posterior Probability 
l   Choose your trees data set as Input Tree File 

(In our example, we chose sample\sample1.trees) 
l   Choose Output File 

(We saved it as Sample1_Final_Tree.tre in sample folder. Sample1_Final_Tree.tre is our condensed tree.) 
 

4.2.2 How to make a condensed treeusing PAUP. (Back to Top) 
l   Define outgroups androot the trees with “roottrees OUTROOT=MONOPHYL;” 
l   Export a tree using “savetrees format=NEXUS” commands. 
 

4.2.3 How to obtain a condensed tree from other phylogenetic programs. (Back to Top) 
If you are using Mrbayes, you should make the condensed tree using Tree  Annotatoror  PAUP*. 
To make a condensed tree using other phylogenetic programs, there are three methods for making a condensed tree: 
Method 1: 
l   Save the tree as Nexus format from whatever phylogenetic program you are using.  
Method 2: 
l   Save the tree as PHYLIP format.  
l   Load the tree into PAUP then export the tree use “format=NEXUS” option. 
Method 3: 
l   Make a text tree file by yourself as the following format: 

tree=(((((6,((2,4),((9,8),3))),1),(7,11)),10),5); 
Important: Trees with polytomies could only be used in Bayesian Binary MCMC and MP analysis! 
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4.2.4The bare essentials of the condensed tree. (Back to Top) 
Condensed tree files may contain various types of commands and information relevant to the program that created 
them (e.g., #NEXUS, Begin trees;, etc.) An RASP condensed tree must contain a line of text that looks like: 
tree=(((((6,((2,4),((9,8),3))),1),(7,11)),10),5); 
Taxon names must be replaced with integers as shown. The unique integer representing each taxon should be the same 
as in the trees file. Other types of information in the condensed tree file may not hinder RASP but are not required. 
 

4.3 How to make Distributions file 

4.3.1 How to make a Distributions file (Back to Top) 
Name the distributions A, B, C, etc. and specify multiple-area distributions 
like BD or ACE. Only letters from A to Ocan be used (Ronquist, 1997, 
2001). 
l   Launch RASP 
l   Select File > Load Trees and navigate to your trees data set 
l   Select File > Save Distribution and save it as a .csv file 
l   Open the your saved .csv file in a text editor or Excel 
l   Input the distributions after the species name like this: 
 
 

Note: RASP can tolerate differences in taxon names between the trees file and the distribution file (i.e., Species_01 in your 
trees file compared to Species01 or Any name in the taxon or B column). RASP 3.x also support load and save distributions 
in PHYLIP format, it looks like that: 

 
4.3.2 How to input distributions in RASP. (Back to Top) 

Name the distributions A, B, C, etc. and specify multiple-area distributions like BD or ACE. Letters from A to O must 
be used (Ronquist, 1997, 2001). 
l   Launch RASP 
l   Select File > Load Trees and navigate to your trees data set 
l   Type your distributions directly into the Distribution column. 
l   Remember to save the distributions you have entered to a file for use in future analyses. Save the distributions as 

a .csv file using File > Save Distribution. 
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4.4How to combine results 

RASP  Results  generated  from  the  same  dataset  with  the  same  method  could  be  combined.  You  could  run  a  method  (like  
Bayarea)  several  times  to  get  several  results,  and  then  combine  them  to  a  single  result.  
Open  [Tools  >  Combine  Results]  to  combine  and  save  different  result.  

 

4.5 How to remove Outgroups 

Distributions of outgroups may pose limitations to historical biogeographic analysis for two reasons. First, an outgroup may 
represent multiple species that are widely distributed. In this case, it is expected that the ancestor of the outgroup originated 
in only one geographic area, but has since spread to many. Another difficulty is outgroup selection. It may sometimes be 
essential to select an outgroup for phylogenetic reconstruction that has a large or unknown phylogenetic distance from the 
ingroup. While this may be suitable for phylogeny, the geographic distributions of more closely related groups may be 
essential for reconstructing ancestral ranges, particularly at deep nodes. We recommend to remove all of the outgroups 
before biogeographic analysis. 
Remove outgroups in RASP is very easy. After the trees data set and condensed tree is loaded, select all of the outgroups in 
the main window. Select [Tools > Remove Outgroups] to save a new trees data set and condensed tree without outgroups. 
Then you cloud close the current data [File > Close Current Data] and reload the new data into RASP. 
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5. Explanation of messages (back to contents) 

1.   Allowing reconstructions will need a larger amount of free space on disk and will take a longer time to run. Are 
you sure to use it? 
User will get this message when the number of taxa is more than 64 and reconstructions are allowed such that

. Allow reconstruction will need a large amount of free space on disk and may take a long time to run. For 

example, processing 100 trees with 84 taxon (max areas of each node =4) needs about 5G free space on disk and will 
take about 2 hours. You may click “yes” to enable “Allow reconstructions” or click “No” to disable it. 

2.   Cannot format the tree! 
The RASP program accepts phylogenetic trees (a trees dataset and a condensed tree) generated by the programs BEAST 
(Drummond and Rambaut, 2006), PAUP* (Swofford, 2003) and MrBayes (Huelsenbeck& Ronquist, 2003). Other tree 
file formats may cause this error. The error may also occur if you are using an accepted format but have syntax errors in 
your file (e.g., a misplaced semicolon, a missing "end" command, etc.). Opening the file using PAUP* may help you 
determine if there is a syntax error, and, if so, what it is. 

3.   Cannot process the computed file! 
There is something wrong with the temp file. Please delete the folder “Temp” and restart the RASP. 

4.   Cannot process the trees! 
There is something wrong with the temp file. Please restart RASP. 

5.   Distributions must be labeled using the letters A to Z only! 
Remember that distributions must be labeled using the letters A to Z only and should include no more than 26 unit areas. 
RASP does not highlight rows containing unrecognized characters. 

6.   Burn-in error! 
The value of the Burn-in must greater than or equal to zero but smaller than the amount the trees. 

7.   Need at least one tree! 
You need at least one tree in the trees file to run RASP! 

8.   Your group of organisms should include no more than 512 taxa! 
Your group of organisms should include no more than 512 taxa and the distributions should include no more than 15 unit 
areas in S-DIVA method. You may try to use BayArea method. 

9.   Please change your system's number format to English! (ex. 3.14 not 3,14) 
The decimal symbol of your system caused this problem. Please go to “control panel->Regional and Language Options” 
and change your "Current format" to English. It is a bug and I will try to fix it in the next release of RASP. 

10.   Distributions should be Continuous letters! Please alter area … 
The distributions in Bayesian method must be continuous letters. For instance: Right, ABCDE; Wrong, ACDEF 

11.   Your group of organisms should include no more than 512 taxa! 
Your group of organisms should include no more than 512 taxa in All method. 
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